We wanted to let you know that the recent issues affecting Mastercard transactions have been fully resolved, and all services are now operating normally.
Mastercard's technical team identified and resolved an issue with their network certificate, which had been causing downstream 3D Secure (3DS) authentication failures.
Impact Window: 09:00 CEST to 10:09 CEST
Current Status: Fully Restored (Success rates have returned to normal baseline levels)
We sincerely apologise for the disruption this may have caused to your checkout experience and your customers.
If you have any questions or if you continue to see any unexpected transaction behaviour, please do not hesitate to reach out to the Gr4vy Support Team.
Best regards,
The Gr4vy Team
Posted Jul 15, 2026 - 02:01 PDT
Identified
We are currently investigating an issue affecting Mastercard transactions.
Time of Occurrence: Since 10:00 CEST
Root Cause: Our third-party provider has reported a downstream issue affecting 3DS with Mastercard transactions.
Impact: Some Mastercard transactions may fail or experience delays during checkout.
Next Update: As soon as the status changes or new information is available.
We apologise for any inconvenience this may cause. We are actively tracking the issue with our provider and will post regular updates here until it is fully resolved.
If you have any questions or concerns, please contact the Gr4vy Support Team.
Posted Jul 15, 2026 - 01:13 PDT
This incident affected: Third-party services (3-D Secure).