Intermittent processing issues in the us-east1 region

Incident Report for Gr4vy

Resolved

The issue affecting our API has now been fully resolved. Gr4vy is internally reviewing the events to prevent similar incidents in the future.

For any affected instances, we'll provide a full RCA in due course.

Thank you for your partnership on this issue.
Posted Jul 18, 2025 - 11:42 PDT

Monitoring

The issue affecting our API is now fixed. We are monitoring closely to ensure the issue is resolved.

Next update: As Google updates their status page (https://status.cloud.google.com/) we'll send a final update.

For any affected instances, we'll provide a full RCA in due course.

Thank you for your continued patience on this issue.
Posted Jul 18, 2025 - 10:54 PDT

Update

The issue affecting our API appears to be fixed, no new errors in the last 30 minutes. We are monitoring closely to ensure the issue is resolved while also waiting for Google to solve the incident on their end https://status.cloud.google.com/

For any affected instances, we'll provide a full RCA in due course.

Next update: As the current status changes.

Thank you for your continued patience on this issue.
Posted Jul 18, 2025 - 09:34 PDT

Identified

We are aware of an issue that is currently affecting our API.

Root cause has been identified and acknowledged by Google at https://status.cloud.google.com/

Impact: Some transactions may be affected, services are normalizing.

Next update: As the current status changes.

Apologies for any inconvenience caused. Regular updates will be provided until the issue is resolved.
Posted Jul 18, 2025 - 09:06 PDT

Update

We are aware of an issue that is currently affecting transactions in the us-east1 region.

Our team is investigating the cause and working to resolve the issue.
Impact: some transactions may be affecting
Next update: As the current status changes.

Apologies for any inconvenience caused. Regular updates will be provided until the issue is resolved.
Posted Jul 18, 2025 - 08:46 PDT

Investigating

We are aware of an issue that is currently affecting our API.

Our team is investigating the cause and working to resolve the issue.
Impact: Some transactions may be affected
Next update: As the current status changes.

Apologies for any inconvenience caused. Regular updates will be provided until the issue is resolved.
Posted Jul 18, 2025 - 08:40 PDT
This incident affected: Gr4vy API.